Windows Phone Developer Tools Beta 7.1 Installation behaviour

Just got the Windows Phone 7.1 Developer Beta SDK installed today and great to see lot of API than the earlier version .

Infact , i got the Developer SDK installed on 3 different machines .

  1. A new Virtual Machine with Windows 7 Professional without the Visual Studio 2010 pre-installed.
  2. Machine with Visual Studio 2010 Professional SP1 installed .
  3. Machine with only Visual Studio 2010 Ultimate installed

The installation on the Machine 1 went on smooth and so is with the machine 2 with Visual Studio 2010 Professional SP1 installed but was struck up the following prerequisite missing message on Machine 3 .

“Microsoft Windows Phone Developer Tools 7.1 (Beta) – ENU

Setup has detected that this computer does not meet the requirements to install this software . These requirements must be met before you can install Microsoft Windows Phone Developer Tools 7.1 (Beta) – ENU .

PreRequisite products

Setup has detected that Visual Studio 2010 Service Pack 1 is not installed on the machine for following products . Please install and retry

* Microsoft Visual Studio 2010 Ultimate .”

So guys , incase you have Visual Studio 2010 already installed on your machine , make sure you have the SP1 too installed before installing Windows Phone 7.1 Developer Beta SDK :)

 

 

If you enjoyed this post, please consider leaving a comment or subscribing to the RSS feed to have future articles delivered to your feed reader.

6 Responses

  1. Even thought I have SP1 installed, it still gives me this message. Thanks microsoft for not fixing this in the installer package.

  2. Make sure that u have installed Windows 7 sp1 and Visual studio 2010 sp1 to meet the requirement.Try it…It will work 100%…

    CheeR$ ~~~

  3. I have the same problem, but I have 2010 SP1 installed on Win 7 SP1 and it’s not the beta 7.1 sdk. I wonder if it is a x64 issue?

Leave a Reply